AX Inovonics Driver Connection Trouble


#1

Hey there,

I’m having trouble getting the demo AX driver functioning properly. I’ve installed a station with the demo version of the AX inovonics driver (csi3inovonics) on a honeywell JACE 6000. I’m trying to interface an EN4000 serial receiver. To do so, i’m using the recommended EN4000 to RS 232 connector from Inovonics directly into the RS 232 port on the JACE. Below is a screenshot of my configuration:

image

As you can see, the network is down. I’ve verified the port, I can see data coming from the receiver, but i can’t get the network to stay up. Any suggestions are greatly appreciated


#2

The serial port being down means the JACE is unable to access that port for some reason. Can you attempt to change the port name from COM1 to any other port and then change it back and see if that brings the port back up? If not, can you watch the application director during this test and provide any output that may be getting thrown indicating the port access failure cause?


#3

This is what the output said when I changed from COM1 to COM3:

image


#4

on a side note, the serial jumper on the AX jace: should that be set to serial shell? in the first screen capture I sent you, the jumper was set to the serial shell position. Before I did this test, I put it back to normal operation


#5

Serial shell jumper would have prevented the 232 port from being used by the station so that would have been a problem. When you changed back to COM1 with the jumper set to normal operation, was it able to bring it out of a down state?


#6

No it did not. I just power cycled the jace and restarted the station, but still no luck:
image


#7

Can you confirm the serialPortPlatformService is a part of the platform services in the station? It should list all the available serial ports and also report if there is a different service already “owning” the COM1 port.


#8

doesn’t seem to be anything:
image


#9

Looking at that screen shot a little closer I noticed that you have an invalid configuration. You need to have the InovonicsSerialNetwork under the InovonicsDriver object. Please add that to the driver section and move the network under it. This should correct your issue.


#10

Awesome! That fixed the problem. Thank you.

That being said, now that the network is up, it seems to be discovering a lot of devices that are not present?

image


#11

Was this a blank network when added or was it copied from another installation that had devices already in it?


#12

This was a blank network. I created it this morning


#13

Any device in range will be picked up. Is it possible there are devices in the area that you were not meaning to integrate that could be powered? If so, you can turn off the auto discovery and remove the ones you don’t care about after the network has been created with the ones you do.