Error while connecting to a device


#1

I am using haystack+ driver and I am trying to configure the device in N4. ( page 8 of the Haystack Driver Guide from Kodaro)

error message: “java.lang.RuntimeException:Test failed”

image

Any help would be appreciated?


#2

Is there a full stack trace in the application error you could provide? If not, could you turn on the device logging for the kodaro driver in the log manager?

It appears you are connecting a Niagara station to another Niagara station via the haystack+ driver, is this correct? If so, could you provide the Niagara versions for both of these installations?


#3

Hi Jonathan:

Right now I am just playing with a dummy station ( with couple of control points ) trying to see If I can connect the N4 with the Skyspark through haystack driver+ from Kodaro, before I try to use this in our clients’ stations.
My dummy station is not connected to any network or any controllers.

I am not sure If I have full stack trace in the application error. I am sorry but I do not know how to turn on device logging ? Could you please give me a hint?


#4

my N4 version/revision is 4.3.58.22.5

and my skyspark is 3.0.12

I am not connecting a niagara station to another station.


#5

If you are connecting Niagara to SkySpark then from that screen shot you provided you are using an invalid URL to make that connection.

What you have: http://192.168.0.9/haystack/

The format for a SkySpark connection can be found in the Configuring the Device section of the guide.

image

Once you update the URL to match the SkySpark project you wish to connect to, this error should go away. If not, you can turn the logging on by using the below image to guide you to the logger configuration section of a station.

image


#6

I changed the URL and still got the same error message.
I tried turning on device logging . please see below.

image


#7

You need to turn on logging at the station level. Right click on the station name to get the correct spy option.

Have you verified the IP and port for SkySpark you have in your URL in the haystack device is accessible via the browser?


#8

I was able to turn on the device logging.
Yes, skyspark’s ip and port is accurate which is http://spark.besp.us:9090

image


#9

Can you expend the health to get the cause of the last connection failure?

Did you see any logging in the application director after you turned on the logging?


#10

Last Fail Cause: org.projecthaystack.auth.AuthException: 403 Auth failed

image

Here is what I have in application director:
FINER [16:05:24 14-Aug-18 PDT][kodarohaystack.HaystackDevice] THROW
org.projecthaystack.auth.AuthException: 403 Auth failed
at org.projecthaystack.auth.AuthClientContext.openStd(AuthClientContext.java:162)
at org.projecthaystack.auth.AuthClientContext.open(AuthClientContext.java:74)
at org.projecthaystack.client.HClient.open(HClient.java:109)
at com.kodaro.haystack.core.HKodaroClient.open(HKodaroClient.java:116)
at com.kodaro.haystack.BHaystackDevice.getClient(BHaystackDevice.java:835)
at com.kodaro.haystack.BHaystackDevice.conectOrPing(BHaystackDevice.java:855)
at com.kodaro.haystack.BHaystackDevice.performConnect(BHaystackDevice.java:601)
at com.kodaro.haystack.message.DeviceConnectMessage.execute(DeviceConnectMessage.java:45)
at com.kodaro.haystack.message.DeviceConnectMessage.run(DeviceConnectMessage.java:36)
at javax.baja.util.ThreadPoolWorker$WorkerThread.run(ThreadPoolWorker.java:277)


#11

This means the user and password you have configured are not authorized to login to your skyspark installation. You need a valid username and password on either the network or the device. If you choose to do it on the device, you need to set the Override Network Auth property to true.


#12

yep. It worked now.

Thank you Jonathan