Transfer CSV BY FTP Or Other Method


#1

I am trying to export my files to a couple of backup drives. Can you use the FTP export without a FTP client on the remote machine or is there a better way to do this they are on my local lan. I tried to put the IP address of the remote machine in with the path and no luck


#2

The FTP export needs an FTP server running at the other endpoint to accept the FTP data. Is there a reason why putting an FTP server at the other end does not work you are trying to overcome?


#3

No I could it is just that I have a NAS drive and two other computers that have been converted to hold this data. This is in a Hospital and they are really forcing us to hold this data on different drives and we have to hold for three years. Everything is is on my local lan and not going offsite. We are running EC-Net 4 and Pulling the points from the jaces and the VAVs to the supervisor then out


#4

I have the FTP server running on a machine and I can access it with Internet explorer from all my machines but when I try with The driver I get this error ftp://192.168.100.242/: invalid IPv6 address


#5

From the documentation concerning the host property.

image

You need to use only the IP address or host name as that entry is invalid.


#6

Sorry about that and I read that and still did it it logs on now but wont send a file here is the ftp log

00094)10/3/2018 9:19:48 AM - (not logged in) (192.168.100.233)> USER NAS01
(000094)10/3/2018 9:19:48 AM - (not logged in) (192.168.100.233)> 331 Password required for nas01
(000094)10/3/2018 9:19:48 AM - (not logged in) (192.168.100.233)> PASS **********
(000094)10/3/2018 9:19:48 AM - nas01 (192.168.100.233)> 230 Logged on
(000094)10/3/2018 9:19:48 AM - nas01 (192.168.100.233)> TYPE I
(000094)10/3/2018 9:19:48 AM - nas01 (192.168.100.233)> 200 Type set to I
(000094)10/3/2018 9:19:48 AM - nas01 (192.168.100.233)> PASV
(000094)10/3/2018 9:19:48 AM - nas01 (192.168.100.233)> 227 Entering Passive Mode (192,168,100,242,214,139)
(000094)10/3/2018 9:20:09 AM - nas01 (192.168.100.233)> QUIT
(000094)10/3/2018 9:20:09 AM - nas01 (192.168.100.233)> 221 Goodbye
(000094)10/3/2018 9:20:09 AM - nas01 (192.168.100.233)> disconnected.


#7

Have you confirmed the ftp server setup will allow you to write to the location defined in the ftp export object? You can test this pretty easily by installing FileZilla client and connect with the same user. Try to create a empty file or folder in the same location and see if it works. If not, you will need to configure user permissions on the ftp server to allow this.


#8

I put in the client and you were right it keeps saying 425 cant open data connection for transfer of “/” so I checked permissions and they are all set. What do you recommend for a FTP server I have never worked with FTP before and so far not much fun


#9

FileZilla seems to be the simplest to setup with a lot of online community support.


#10

I have filezilla working and sending out all my data to different servers. I cant get the file export to work it says it has sent the file but nothing is there. I have tried with the default setup and have done custom ones here is an example of one it says it sends file but nothing there.
file:^stations/administration/shared/%parent.displayName%_%time()%.csv


#11

That looks like you are using a file path outside of your station. Does that file path exist under your “Files” section of your station? If you don’t have the path “stations/administration/shared/” already in your station File section, then the export will not succeed.