Csi3sys600 driver points faulting


#1

Siemens System 600 to Jace 8000 via serial using HMI port, new install, at first default baud rate was 19200, things got updated quick, but many points would drop out and go faulted, we slowed down to 9600 and points still go faulted. Read Fault:Poll message 1: no response or message 8:P<0> or message 8:S<0> or message 8:P<0>W<0>P<0>1<0>.
I have 32 TEC’s and 8 Cab’s MEC’s.
TEC’s are stable, points are stale at first look, but update within a few seconds.
Cabinet 7 is my worst, 25 points with all faulted except 4 points are updated and ok, view all points at once and some points come and go, many stay faulted, over time all will update and say ok, but it takes awhile.
I have tried batch poll true on a device, but it didn’t appear to help.


#2

Enabling batch polling can potentially have unexpected negative behavior of the field devices integrity, see Carefully Use Batch Polling section of the user guide for specific concerns.

From the user guide concerning baud rates:

High baud rates. While System 600 / Apogee support higher baud rates, our experience has been that anything above 9600 is unstable. Changing the baud rate requires System 600 programming knowledge. If you know what you are doing, you can use the tunnel feature of this driver to easy access the Siemens HMI.

So you definitely want to stick with 9600 and do not go above this for stability purposes.

There are a number of troubleshooting steps in the guide as well but generally the most effective is to increase the timeout value and/or slow down the polling rate. Finding a good balance of speed and stability is always a little tricky to get right on every installation due to this being a notoriously slow protocol that is very easy to clog up if polled too quick or with too large of requests.


#3

I will stick with 9600, I enabled batch polling on all Cab’s and it seemed to maybe help, but I still have points faulting. I have now changed to slow poll freq, time out to 50000ms, restarting station to see how it looks after these changes.
I have also changed the treads from 4 to 250?


#4

See this note concerning threads from the user guide:

Thread Pool – Set the number of threads to twice the number of networks. This controls the number of threads used to execute all actions of all objects in the network. This includes serial communications additional threads will not improve serial performance.