CSV will not populate with historical data into history


#1

I have a CSV with 2500 lines of csv’s, and 12 months of data separated by months. When I do the import, it only imports the last months value into the history.


#2

If the history already had data before the import, it won’t back fill the past data and will only go forward. You will need to clear out the history and re-import or you can set the “Clear History When Older” flag to true on that history extension. That will clear the entire history when detecting an older record and rebuild the history from the current import.


#3

I did that several times and also used the clear history function. I still have only the last value being imported.


#4

Johnathan,
Thanks for the response. I think I got it. I had the Timestamp Column pointing to the incorrect Column. It was set to the default ‘timestamp’ and I have it called ‘ServiceDate’ . Works great!