Platform Host File


Using running N4 station as a template, we set up the Platform Host as “localhost” in place of the default Kodaro setting. Now we are unable to access the platform with set password. Station is running and accessible, platform credentials do not work. Any help would be appreciated.


Can you elaborate on the process by which you changed the platform host? Have you also attempted to access the platform with the IP address instead of the host name? If you are running a station, then that means the gateway has been commissioned so the default platform login would have been changed to allow that. Make sure you are not using the default platform credentials.


Under the Platform TCP/IP settings, the first entry is the Host Name. We changed this to “localhost” to match the system we were transferring along with the DNS settings. Once the system rebooted, the set platform credentials were no longer valid, they are not the default credentials… We are trying to access using the IP address, not the host name.


Have you attempted to connect on the secure and insecure platform ports?


Yep, same result on both ports.


With a Jace platform, you can change the jumper and put it in serial shell mode to reset the credentials to default. Is there some method for performing a reset on a Kodaro platform?


If you re-run the installer and select the option to preserve the user and station data, it will reset the platform credentials and require commissioning again. This will also make a backup of the current installation during that process.


After regaining access, I tried running the installer. I get the following error.


Trying to stop the current installation using the ‘docker’ command, I get the following:

Without access to the Platform, I am unable to stop the station. Is this the reason for the error? What are the steps to stop the current installation and re-load? Thanks in advance.


Unless the currently logged in user has been added to the docker group, you will need to run all commands related to docker with the sudo command to act as root.

You can run the command you tried by adding sudo in front of it or you can navigate into the installer directory and run the command: sudo ./ for the same effect.


I was able to stop the installation and re-install, choosing to preserve the existing station and I.P. settings. Same result, not able to access the platform. I ran the installer again and wiped out the existing station data, preserving only the I.P. settings, same result. Here is a pic of the log in dialog, same result on secure platform. What can I try next?


That IP does not look right to me. Was this determined through the ifconfig command via the console? You should be able to run that command and determine the IP address of both ports and match to the one you are currently plugged into. The one indicated by eth0 maps to port 1 and eth1 maps to port 2 on the gateway. docker0 should be ignored which I believe is the IP being used in the screen shot.

See this post for factory set IP addresses.


That’s the issue. We are logging into port 0 at 10.18.xx.xx and when attempting to access the platform, it is routing to the “localHost” at Is there a location we can edit this setting? If we had the docker credentials, would this allow access to the platform and if so, what are the docker credentials? Below is a clip of the setting changed on the TCP/IP service that caused the issue. The setting was edited to “localhost” to match a Jace being replaced by this device and its DNS settings.


Thank you for that information. I have been able to recreate the scenario as described and it appears that usage of localhost as the hostname currently seems to have unintentional routing issues to the wrong location. I tested with the hostname “gateway” without issue so it seems this issue only presents itself with the usage of the word localhost. At this point I do not have a solution to that but please follow the below instructions to recover platform access.

To return access to the platform by resetting the hostname, follow these steps.

  1. Determine what you want the hostname to be. For now, localhost should not be used. If you want it to factory defaults, this will be the serial number/service tag that can be found directly over the the RS232 port.
  2. Verify the current hostname: sudo cat /etc/hostname
    This should return: localhost
  3. Change the hostname with the following command (replace newHostname with desired hostname):
    sudo docker exec Niagara_4.2.36.34 sh -c “echo newHostname > /niagara/hostname”
  4. Verify the hostname changed: sudo cat /etc/hostname
    This should return whatever your “newHostName” value was
  5. Restart the gateway: sudo shutdown -r now

You will likely need to close/remove the platform connection from your workbench to properly clear out any cached data with the bad hostname configuration before you can reconnect to the platform.

Let me know if you have any further issues.