Webservice in fault (permission denied) iotium deployment


#1

Anyone having a issue with the webservice restarting? I have a error message that states permission denied. Is this a licensing issue?

niagara>INFO [18:57:01 18-Dec-17 UTC][web] Jetty stopped.
SEVERE [18:57:01 18-Dec-17 UTC][javax.baja.web.BWebServer] failed: java.net.SocketException: Permission denied
java.net.SocketException: Permission denied

image


#3

This is not due to a licensing issue but due to the underlying security of the operating system on ports below 1024. Since Niagara does not run as a root user for security reasons, it cannot directly access ports below 1024. In this case, the ports of 80 and 443 will need to be adjusted to something higher. Switching to ports 8080 and 8443 are a pretty common starting place when this scenario presents itself.


#4

Issue Description: Webservice in fault (permission denied) iotium deployment
Area Path:
Build/Version Number: Iotium: 956.2.0
Hardware: Dell Gateway 5000
Operating System: iotium
Niagara Software Version: Tridium 4.2.36.38
Steps To Reproduce: start a default station, webservice is enabled by default, error messages show up in application director or you can look at the service.


#5

That worked. thanks.


#6

Now that the web service is running, for http…I can’t get past the prelogin…It just keeps asking me to enter my username. Is there something else I need to configure?


#7

If you continually get redirected to the prelogin after entering a user name, that is generally an indication that you are using a login that does not exist in the station.


#8

That isn’t true. The pre-login has you enter the user name, it can be anything. The next page has you enter your password. If the username doesn’t exist or you enter the wrong password you get the same error…login failed.

Regardless, I did verify the username/password via workbench.

image

This user doesn’t exist.-asdfdasf, yet I can still move on to the second screen…the iotium version doesn’t even allow you to get to this step.

image


#9

The login has nothing to do with the IoTium version as it is just a version of Niagara that runs on that specific operating system. At this point we will need to investigate why Niagara is not allowing you to login.

Can you provide the following to help resolve this issue?

  1. A screen shot of the web service configuration you currently have in the station.
  2. A screen shot of the user AX property sheet you are attempting to login with.
  3. A screen shot of any error from the Application Director during a failed attempt with this user from the web interface

#10

Rebooting Dell 5000 fixed it. Working as expected. The odd thing, was that during all of this https worked. (on port 8443)